Play Now Login Create Account
illyriad
  New Posts New Posts RSS Feed - 01 July 11 - Memory Leak patch
  FAQ FAQ  Forum Search   Register Register  Login Login

Topic Closed01 July 11 - Memory Leak patch

 Post Reply Post Reply
Author
GM ThunderCat View Drop Down
Admin Group
Admin Group
Avatar
GM

Joined: 11 Dec 2009
Location: Everywhere
Status: Offline
Points: 1993
Direct Link To This Post Topic: 01 July 11 - Memory Leak patch
    Posted: 02 Jul 2011 at 02:18
Memory leak patch and other fixes

EDITING FINANCES
The Edit finances page for newly formed alliances would error until the first alliance tax was collected. This has now been fixed.

CHAT SERVER
Performance improvements have been made to the chat and notification server so they should perform better under heavy load.

WORLD MAP
Some players prestiging their caravans to near instant were causing a divide by zero error for people viewing the map - this has how been fixed.

TRADE MOVEMENTS/SEND TRADE
Trade movements that were about to complete before the next second would cause an issue when viewing the trade movements page - this has now been fixed.

MILITARY MOVEMENTS/SEND ARMY
Military movements that were about to complete before the next second would cause an issue when viewing the trade movements page - this has now been fixed. 

DIPLO MOVEMENTS/SEND DIPLOS
Diplomatic movements that were about to complete before the next second would cause an issue when viewing the trade movements page - this has now been fixed. 

MEMORY LEAK
After quite a major overhaul, including ditching some buggy 3rd party libraries; we believe we have shut down most of the major browser memory leaks. We are considering deleting chat and notification messages from the side panels after a certain number, as these will just keep building up. However this would also mean if you left your browser open overnight, you'd only be able to read the last 100/1000 messages rather than all of them. Naturally this led to...

SERVER BLIP
All sorts of issues, including players not being able to log in - this has now been resolved.

Note:
The changes for the memory leak fix were fairly extensive so may have caused knock-on issues we are not aware of. Please keep your eye out for anything not behaving in the way it should or that has changed and submit an in-game petition. Although please make sure you have refreshed your browser or recently logged in to ensure you have picked up the latest changes.

TC


Edited by GM ThunderCat - 03 Jul 2011 at 21:55
Back to Top
Dakota Strider View Drop Down
Greenhorn
Greenhorn
Avatar

Joined: 03 May 2011
Location: USA
Status: Offline
Points: 62
Direct Link To This Post Posted: 02 Jul 2011 at 02:52
Since around the 0:600 server time, I have started experiencing a bug in the Mail system.  When making deletions, I am kicked back to the Herald page.  Others have also experienced this, and some said it is a Firefox problem only.  That may be, but since I have not had any new updates from Firefox for a couple weeks, I do not believe the problem originated with them.   It looks like you have made a lot of technical fixes, and kudos to that.  But of course it is the nature of this medium for one fixed problem to lead to another bug.  Good luck.
Back to Top
Starry View Drop Down
Postmaster
Postmaster
Avatar

Joined: 20 Mar 2010
Status: Offline
Points: 572
Direct Link To This Post Posted: 02 Jul 2011 at 02:57
FYI Dakota Strider, I had an issue when I first logged in several hours ago, no problems since I reloaded the browser.    I am running FF 5.0 and I'm not having the issue with mail.   
CEO, Harmless?
Founder of Toothless?

"Truth never dies."
-HonoredMule

Back to Top
Dakota Strider View Drop Down
Greenhorn
Greenhorn
Avatar

Joined: 03 May 2011
Location: USA
Status: Offline
Points: 62
Direct Link To This Post Posted: 02 Jul 2011 at 04:05
I had tried restarting the browser before, with no success.  However, I just restarted my computer, and that seemed to do the trick.  No more problem.
Back to Top
Dakota Strider View Drop Down
Greenhorn
Greenhorn
Avatar

Joined: 03 May 2011
Location: USA
Status: Offline
Points: 62
Direct Link To This Post Posted: 02 Jul 2011 at 04:47
I stand corrected.  The error is still there.  Now it kicks me to the trade movement page, instead of the Herald.  Tried to restart the browser, and computer again.  No change.
Back to Top
GM ThunderCat View Drop Down
Admin Group
Admin Group
Avatar
GM

Joined: 11 Dec 2009
Location: Everywhere
Status: Offline
Points: 1993
Direct Link To This Post Posted: 02 Jul 2011 at 12:20
Prestige purchases, facebook credits and mail issues all fixed
Back to Top
Dhenna View Drop Down
Wordsmith
Wordsmith
Avatar

Joined: 09 Jun 2011
Location: Denmark
Status: Offline
Points: 156
Direct Link To This Post Posted: 02 Jul 2011 at 14:08
Still having the "2 x enter" bug in both IE8 and Vista.
Back to Top
Brids17 View Drop Down
Postmaster General
Postmaster General
Avatar

Joined: 30 Jul 2010
Location: Canada
Status: Offline
Points: 1483
Direct Link To This Post Posted: 02 Jul 2011 at 14:26
Hmm...I wonder if this was the problem SC was thinking about...
Back to Top
Dhenna View Drop Down
Wordsmith
Wordsmith
Avatar

Joined: 09 Jun 2011
Location: Denmark
Status: Offline
Points: 156
Direct Link To This Post Posted: 02 Jul 2011 at 15:21
So, I remembered that yesterday evening the "2 x enter" bug was suddenly gone, and I tried remmbering what I did prior to it fixing itself, and tried it again just now, and it worked.
 
Here is what I did:
  • Click world map icon
  • Click zoom out once
  • Type in "20" in url instead of "5"
  • Move one square in some random direction
  • Go back to city map

And voila, no more "2 x enter" bug.

Very very odd.
 
EDIT: Worked with IE8, not with Vista.
 
2nd EDIT: Bug comes back when you switch between your own account and one you sit for, and doing the whole world map thing fixed it again.
 
3rd EDIT: This "fix" only works for GC, not AC.


Edited by Dhenna - 02 Jul 2011 at 16:14
Back to Top
GM ThunderCat View Drop Down
Admin Group
Admin Group
Avatar
GM

Joined: 11 Dec 2009
Location: Everywhere
Status: Offline
Points: 1993
Direct Link To This Post Posted: 02 Jul 2011 at 21:37
All issues we are aware of other than having to click twice on enter or use "send" to post chat messages in IE are resolved.

Please raise an in game petition if you experience any other issues.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.07
Copyright ©2001-2016 Web Wiz Ltd.